
Adobe® GoLive™ 5.0 ReadMe 
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Please read and understand the license agreement included with this software prior to installing  
Adobe GoLive 5.0. 
Note that GoLive cannot run from the CD; the components must be installed onto your hard drive 
and run from that drive. 
 
This file contains last-minute product information, updates to the Adobe GoLive documentation, and 
troubleshooting tips. Please visit the Adobe User to User Forums to share thoughts, participate in discussions 
and interact with other GoLive users. 
 
This ReadMe includes the following sections: 
1. System Requirements. 
2. General GoLive 5.0 Notes. 
3. Installation Notes. 
4. GoLive Dynamic Link Notes. 
5. Adobe Integration Notes. 
6. GoLive WebDAV Notes. 
7. Undocumented Features and Shortcuts. 
8. Changed Features and Shortcuts. 
9. Tips for working with GoLive 5.0. 
10. Known Issues. 
 
 
------------------------------------------ 
 
1. System Requirements 
 
Macintosh® 
• PowerPC® Macintosh 
• Mac OS version 8.6, or 9.0 
• 48 MB of RAM (64 MB or more recommended)* 
• 50 MB of hard disk space 
• CD-ROM drive 
• Monitor resolution 1024x768 or higher recommended 
*RAM requirements based on all modules being active 
 
Note: Adobe strongly recommends turning on Virtual Memory to optimize RAM use. 
 
Windows® 
• Pentium® 200 MHz processor or higher. 
• Windows 98, Windows 2000, Windows NT® 4.0 with Service Pack 4. 
• 48 MB of RAM (64 MB or more recommended)*. 
• 50 MB of hard disk space. 
• CD-ROM drive. 
• Monitor resolution 1024x768 or higher recommended. 
*RAM requirements based on all modules being active. 
 
Note: For GoLive Dynamic Link you should run Service Pack 5 on the Windows NT 4 server side. 
 
 
------------------------------------------ 
 



2. General GoLive 5.0 Notes 
 
REGISTRATION 
Please complete your registration card and mail it today. You can also use the registration software provided 
with Adobe GoLive 5.0 to register your copy (under Registration ... in the Help menu). 
By registering, you qualify to receive technical support and important product update information. 
 
Serial Number 
You will find the serial number for your copy of the software on the printed registration card and on the CD 
sleeve. If your serial number does not work, please contact Adobe Customer Support. 
If downloading from the Web, go to Personal Adobe, select View Your Order History (US and Canada only), and 
click the appropriate Order Number to view your serial number. 
 
Adobe GoLive SDK 
With the Adobe GoLive SDK you  can extend the software's functionality via JavaScript extensions. Adobe 
GoLive 5.0 includes both a JavaScript interpreter and Debugger application to facilitate this process. The 
scripting and design layout of these extensions can be accomplished via GoLive software's standard features. 
Documentation on how to use the GoLive SDK, as well as a set of sample extensions are stored in a separate 
folder titled Adobe GoLive SDK 5.0r1 on the CD-ROM, or in the download archive (on Windows you can install 
the SDK folder via Custom install option). 
New versions of the SDK, including further documentation and additional samples will be posted on the GoLive 
site on www.adobe.com. Please use this site to pick up any news regarding the GoLive SDK. 
To install an SDK sample, simply drag the appropriate sample folder into the Modules > Extend Scripts folder 
within the application folder,and make sure that you enable the Extend Script module via the  
Adobe GoLive 5.0 Preferences. 
 
Online Help 
Please note that you will find the most complete documentation on GoLive 5.0 features under GoLive Help in 
the Help menu. This online help covers the content from the printed user guide in its entirety, with additional 
documentation regarding: 
• WebDAV functionality. 
• QuickTime editor functionality. 
• Using and creating Actions. 
• Web Settings. 
• HTML and CSS. 
• Creating Forms. 
• Web Technology Support. 
• Automating operations using AppleScript. 
 
GoLive 5.0 Educational Version 
Please note that the GoLive 5.0 Educational version does not include WebObjects functionality/support. 
Educational version users may ignore WebObjects references in the User Guide/Online Help. 
The Adobe GoLive 5.0 Educational version does not include Apple WebObjects functionality. All other GoLive 
5.0 versions support WebObjects via the WebObjects module. An extended description of the Apple 
WebObjects functionality can be found in the document WebObjects.pdf that will be installed with GoLive 5.0. 
 
GoLive 5.0 Tryout Version 
If you have a GoLive 5.0 Tryout version, please note that it will expire after 30 days of use. You have the option 
to purchase the full version of GoLive 5.0, and have your tryout version unlocked any time. For further details, 
please refer to the instructions in the Tryout installer introduction.  
 
Plugins 
The Plug-ins (Mac)/Plugins (Win) folder is reserved for third-party Web browser plugin extensions. Copy 
your browser's plugins folder to the Plug-ins/Plugins folder in the Adobe GoLive 5.0 application folder. This 
gives GoLive 5.0 the same multimedia and viewing options as your browser. The SVG Viewer plugin is 
automatically installed to the Plug-ins/ Plugins folder with the GoLive 5.0 installation. 
 

http://www.adobe.com/


Acrobat® Reader™ 
Some of the accompanying documents are in Portable Document Format (PDF). Use Adobe Acrobat or Acrobat 
Reader to view these files. You will find the latest Acrobat Reader release on the application CD. You can also 
download it from www.adobe.com. 
 
Microsoft Common Control 
If you want to run GoLive under Windows without Internet Explorer installed, you should install the Microsoft 
Common Control Update that you will find in the Extras > Microsoft Updater folder on the Windows CD. Please 
read the license agreement located in the same folder before installing. 
 
 
------------------------------------------ 
 
3. GoLive 5.0 Installation Notes 
 
Your copy of Adobe GoLive 5.0 has an installer application. For Macintosh operating systems, it will prompt you 
to quit any other open application in order to run the GoLive 5.0 install process. Please note that GoLive 5.0 
cannot run from the CD; the components must be installed onto your hard drive and run from that drive. For 
details on the installation process please refer to the InstallReadMe.pdf that is located on the application CD. 
 
Possible Extensions Conflicts on Macintosh 
The more extensions active on your Macintosh system the longer the Finishing installation process may take. 
Also, there may be incompatibility between the installer program and the system extension for Microsoft 
IntelliMouse. Adobe recommends all system extensions be turned off prior to beginning the GoLive 5.0 
installation process on Macintosh systems. 
 
Macintosh Install Options 
You will have the choice between Easy and Custom. Easy Install installs the Adobe GoLive 5.0 application 
along with all components. Custom Install lets you choose which components and dictionaries you wish to 
install. 
 
Windows Install Options 
When installing Adobe GoLive 5.0 you have the choice between Complete, Custom and Compact Install. 
Complete Install will install the GoLive 5.0 application along with all components to your hard disk, whereas 
Compact Install leaves out the Site Templates and the GoLive Dynamic Link Examples files. Custom Install lets 
you choose which components and dictionaries you wish to install. 
 
After installation of GoLive 5.0 you can run the installer again at any time in order to modify, repair or remove 
your installed version of GoLive 5.0. In order to re-install your existing GoLive 5.0 version, you must perform a 
Remove which may also delete all your custom files (e.g. actions, shortcuts, site templates). 
 
Note: If you register the GoLive Dynamic Link sample files to a local Web server (details see below), you must 
enable the virtual root before performing a Remove. Otherwise, e.g. a re-installation of GoLive 5.0 will not be 
possible. 
 
Please note that you will be able to install different language versions of GoLive 5.0 on one Windows machine.  
 
 
Installing Dictionaries 
When performing Easy Install on Macintosh or Complete/Compact Install on Windows, respectively, only the 
dictionaries corresponding to the product language are installed. Additional dictionaries of your choice may be 
installed via Custom Install. Adobe GoLive 5.0 allows you to switch between language dictionaries within the 
application at any time. 
 
Modules 
The following Adobe GoLive 5.0 Modules are disabled by default: GoLive Dynamic Link, Encodings,  
Find by Content (Mac only), and WebObjects (WebObjects Module is not included with the GoLive 5.0 
Educational version). The Modules Manager in the program’s Preferences allows you to enable or disable 
modules to customize the feature set. 
 

http://www.adobe.com/


SVG Viewer 
The SVG Viewer is installed into the Plug-ins (Mac) or Plugins (Windows) folder with the GoLive 5.0 installation. 
For proper installation, please quit any Web browser before installation. When the SVG Viewer is installed, it will 
increase the default memory allocated to Netscape Navigator/Communicator and Internet Explorer slightly. 
 
Previous GoLive versions 
Installing Adobe GoLive 5.0 does not alter GoLive versions prior to 5.0 that are installed on your hard drive. 
GoLive 5.0 does not overwrite or share the System Preferences of installed versions prior to 5.0 (on Macintosh 
systems GoLive 5.0 reads the GoLive 4 preferences and saves them in a file titled Adobe Golive 5.0 Prefs). 
 
 
------------------------------------------ 
 
4. GoLive Dynamic Link Notes 
 
GoLive Dynamic Link Server Requirements 
You must have the following installed on the Web server side: 
• Windows NT 4.0 server or greater. 
• Service Pack 5. 
• IIS 4.x. 
• ASP 3.x. 
 
Note: You must have a Windows server set up in order to run Dynamic Link and access ASP servers. 
 
GoLive Dynamic Link Examples 
Adobe GoLive 5.0 offers a set of example files to get familiar with the use of the GoLive Dynamic Link for ASP 
module. These examples are pre-installed with Easy Install (Mac) or Complete Install (Windows) and can also 
be installed manually via Custom Install. 
 
GoLive Dynamic Link Examples Setup 
• You must upload the entire directory config and all four subdirectories actions, databases, include,  
• and info. 
• You must be granted full read/write access to these directories as well as Run Scripts permission. 
• Your ODBC compliant database, like e.g. Microsoft Access 97 or later, goes in the directory 

\config\databases. 
• If you plan to have users write to your database, they must be granted proper respective rights to the 

database, otherwise they will need read rights. 
• Note: The \config\include subdirectory has a file called friends.asp. This file can be edited with either GoLive 

software or a plain ASCII editor. It must contain at least one static IP address for your development 
machine, or you will not be able to upload your database, and you will receive error messages instead. 

 
Registering the GoLive Dynamic Link Sample Files to a Local Web Server 
To make use of the samples in the Dynamic Link > Examples folder, you must register them to a local Web 
server. Basically, you can connect a directory to a Web server either  via the contextual menu of the directory, 
or via the administration tool of the server.  
 
Connecting via the contextual menu:  
1. Locate the demo folder of the Dynamic Link examples (typically C:\Program Files\Adobe\GoLive 

5.0\Dynamic Link\Examples\asp\demo).   
2. Right-click the demo folder icon, and choose Properties from the context menu.  
3. In the demo Properties dialog box, choose the WebSharing tab, and click the Share this Folder  
4. radio button.  
5. In the Edit Alias dialog box, use the Alias text box to name the virtual directory on the server.  
6. Enter golive as the name of the site. Only golive will work.  
7. Make sure that at least the Read and Scripts access options are checked at the bottom of the  
8. dialog box, then click OK.  
9. In the demo Properties dialog box, click OK.  
 



Connecting via the administration tool:  
Depending on the Web server you are using, one of the following administration tools will be provided:  
 
• Personal Web Manager (provided when working with Personal Web Server).  
• Internet Services Manager (provided when working with IIS).  
 
To connect via the Personal Web Manager:  
1. Open the Personal Web Manager provided with your Microsoft Personal Web Server application.  
2. In the left pane of the Personal Web Manager window, choose Advanced.  
3. In the scrolling pane listing the virtual directories, select the Home directory, then click the Add button. 
4. In the Add Directory dialog box, click the Browse button, and navigate to the directory containing the content 

you want to publish. Alternatively, type the path into the Directory text box.  
5. Use the Alias text box to name the virtual directory. Enter golive as the name of the site. Only golive  
6. will work. 
7. Make sure that you have at least checked the Read and Scripts access options, then click OK.  
 
To connect via the Internet Services Manager:  
1. Locate the Default Web Site, and choose New Virtual Directory from the context menu that opens  
2. when right-clicking its icon.  
3. The New Virtual Directory Wizard will guide you through the directory setup process as follows:  
• In the Alias to be used to access the virtual directory text box, type the name of the virtual directory.  
• Enter golive as the name of the site, then click OK.  
• Either enter the path to the real directory into the Enter physical path... text box, or use the Browse button to 

navigate to the directory containing the content you want to publish. Then click Next.  
• In the following dialog box, specify the access permission as desired. Make sure you have at least selected 

the Read and Scripts options, then click Finish. 
 
 
GoLive Dynamic Link Instructions and Troubleshooting 
To get started with Dynamic Link and the demo files, go to http://localhost/golive/ (provided the sample files 
delivered with GoLive Dynamic Link have been registered to your local Web server), where you will find step-by-
step instructions. GoLive Dynamic Link functionality is described in more detail in the GoLive 5.0 User Guide 
and Online Help. 
 
Also, you can have your server settings checked for possible problems automatically via the troubleshooting.asp 
page included with the Dynamic Link samples in the  
Dynamic Link > Examples > asp > demo > config > info folder.  
Go to http://localhost/golive/config/info/troubleshooting.asp to view the diagnostic result  
with your Web browser. 
 
Access 2000 Databases 
To help ensure compatibility with Microsoft Access 2000 databases you need to install version 2.1 or later of the 
Microsoft Data Access Components (MDAC),  available from http://www.microsoft.com/data/. 
 
Creating an E-Commerce Site 
In the GoLive 5.0 User Guide, it says that for Creating an E-Commerce Site > Connecting the Checkout Page to 
use the following command: 
<img src= imageName.gif onclick= formName.reset()> 
This needs to be 
<a href=#><img src= imageName.gif onclick= formName.reset()></a> 
to function properly in Netscape Navigator. 
 
Link Action 
The User Guide refers to a Link To option in the GoLive Dynamic Link palette. This option has been renamed to 
Link Action. 
 
Database Tables containing a primary Key  
The Dynamic Link module does not properly handle database tables containing a primary key that is computed 
from multiple fields. Please contact Adobe Technical Support for the latest information and workaround for this 
issue. 

http://www.microsoft.com/data/


------------------------------------------ 
 
5. Adobe Integration Notes 
 
No Support for CMYK Images 
GoLive 5.0 does not support CMYK images (neither native PSD nor TIF files in CMYK mode). When trying to 
import a CMYK image, GoLive 5.0 will not process it, and may even crash. 
 
Importing Layered Photoshop® Files as HTML 
1. Choose File > Import > Photoshop as HTML.  
2. In the standard selection dialog box, navigate to the layered PSD which you want to import.  
3. Select the folder where you want to save the layers (for example, a folder within your Web site folder), and 

click Open.  
4. In the Save For Web dialog box, specify the optimization settings for each layer.   
5. The Save for Web dialog box comes up for each individual layer to let the user set the desired Web format. 

For complex multiple-layered objects, you may wish to only set the format once and then apply the same 
setting to all the remaining layers as well. To accomplish this, press the Ctrl key while confirming your 
settings in the Save for Web dialog box. The latest settings will then automatically be applied to any 
remaining layers. 

6. Ctrl-clicking the Cancel button cancels the Save for Web dialog box for all the following layers. This can be 
especially useful and time saving, if you realize that you did not select the file you wanted. 

7. All layers, including the first layer (normally the Photoshop background layer), are imported into individual 
floating boxes. Optionally, the user may instruct GoLive to import the first layer as a background image. To 
import the first layer as a background image, press the Option key (Mac) or Alt key (Windows) while 
choosing File > Import Photoshop as HTML. If the first layer is smaller than the page it is imported into, the 
layer will tile to fill the page. This is standard behavior for any background image on a Web page. 

 
Note: To successfully import Photoshop layers as HTML, ensure that the Photoshop file to be imported 
meets the following conditions:  
- The image may not contain any slices.  
- The layers may not have effects or layer sets assigned. (Any mask or opacity settings assigned to a layer 

will be ignored when importing it into GoLive) 
Tip: Since the layer information might be more than what is seen in Photoshop, we recommend cropping the 
image before importing it into the GoLive document. 
 
 
Importing Photoshop® Layers as Sprites: 
GoLive lets you import Photoshop layers as sprites. The great benefit of this is that you can do all your design 
and layout of the sprites in Photoshop (including rollover images, and so on), then import it into the QuickTime 
movie, and bring it to life automatically without the need to reposition the sprites or assign the rollover behavior 
manually. To accomplish this, be sure that the layer name extensions of the Photoshop file match those defined 
in GoLive. 
 
To import Photoshop layers as sprites: 
1. In Adobe Photoshop, name each layer with the appropriate name, such as Layer_main, Layer_over, and 

Layer_click. Save the file and close Photoshop. 
2. In Adobe GoLive, create a sprite track, and select it in the Tracks list. 
3. In the Sprites tab of the Sprite Track Inspector, do the following: 

• Select the Resize Sprite Track check box, if you want the Sprite track to have the same size as the 
Photoshop file you are going to import. 

• Select the Import Background layer check box, if you want the background layer of the Photoshop file to 
be imported as well. Deselecting this option prevents the background layer from importing. 

• Make sure that the layer name extensions displayed (default settings: main, over, click) coincide with 
those of the Photoshop file. If necessary, make appropriate changes by entering the actual layer name 
extensions into the respective text boxes. 

• Click Import. 
4. Select your Photoshop image, and click Open.  
5. In the Compression Settings dialog box box, choose the desired settings, and click OK. 
 
 



Tracing Sliced Images 
You can import a sliced PSD file as a tracing image. However, when cutting out a section, bear in mind that you 
can only make selections within the borders of a single slice. GoLive cannot handle selections that cover 
several slices. 
 
Aligning Tracing Images 
The User Guide/Online Help states that you may align the tracing image relative to a selection in the document. 
Please note that you cannot align a tracing image to a selected table cell or floating box in which you want to 
insert it. You may align it to text that is selected in a table cell, however. 
 
Removing a Tracing Image 
1. With a tracing image inserted in your page, choose Window > Tracing Image to bring up the Tracing Image 
palette.  
2. In the palette, deselect the Source check box provided at the top left. 
 
Integrating Smart LiveMotion™ Objects 
When linking to a LiveMotion source file, an additional Conversion Settings dialog box now prompts you to 
confirm the SWF destination format chosen by default. In the Conversion Settings dialog box, click OK. 
LiveMotion launches, comes to the front, and generates a ShockWave Flash target file. After a few moments, 
the GoLive dialog box box returns to the front. Be sure to save the converted image to your site folder or a folder 
inside your site folder when  prompted, otherwise the file will be saved to a location outside the site root folder, 
causing the resulting link to be invalid. 
 
LiveMotion Export Settings 
In the LiveMotion Export Settings, SWF must be chosen as the export format so the integration in GoLive 5.0 
will work properly. Also, for best results you should set the Quality to 100 per cent in the LiveMotion Export 
Settings. 
 
Managing Links attached to LiveMotion Objects 
You can easily add animated objects to your GoLive document by adding a Smart Object placeholder, and 
linking it to an animated LiveMotion file. The Smart Object will automatically come to life in your GoLive 
document. To preview the results, switch to a browser. 
 
In contrast to Photoshop objects, LiveMotion objects are not editable in GoLive. Within GoLive you cannot 
attach any action nor create rollover effects. However, you can modify a link originally attached in LiveMotion by 
using the In & Out Links palette.   
 
To modify a link originally attached in LiveMotion:  
1. In the Site window, select the page to which you have added the Smart LiveMotion object.  
2. Choose Window > In & Out Links.  
3. Use the Point & Shoot button to link the Smart object with another file within your site folder. 
 
 
Sun Microsystems StarOffice™ GIF files 
GIF files exported in RGB mode from StarOffice 5.1 can lead to a program crash when placed  
in GoLive 5.0 for Windows. 
GIF files exported from StarOffice 5.2 can be placed in GoLive 5.0, but will not be displayed correctly. 
 
 
------------------------------------------ 
 



6. GoLive WebDAV Notes 
 
WebDAV Contextual Commands 
The contextual menu commands Refresh Lock Status and Reset Lock Status have been removed from the 
context menu that can be brought up in the server pane of the Site window when connected to a WebDAV 
server. Any description on these commands found in the GoLive User Guide/Online Help is obsolete. 
 
GoLive WebDAV Check In Dialog 
To make the Check In dialog box reappear after you have selected the Don't show again 
check box, press the Option key (Mac) or Alt key (Win) while choosing the Check-in command 
from the context menu. 
 
GoLive WebDAV Apache Configuration 
You can speed-up Apache's performance by modifying the server configuration. Deselect KeepAlive support, 
and the client-server communication will be much faster.  
 
GoLive WebDAV Memory Allocation 
Since insufficient memory resources may cause performance problems while synchronizing large sites, we 
recommend to add some extra memory to the GoLive application. 
 
GoLive 5.0 WebDAV and mod_dav 1.0 or higher: 
To fully use GoLive software‘s WebDAV functionality with the mod_dav 1 module installed on your Apache 
server, you must change the mod_dav configuration. The reason for that is that mod_dav 1 does not support 
infinite PROPFIND requests by default. The DAVDepthInfinity directive created to prevent such requests 
defaults to off.  
 
Before changing the configuration, bear in mind that this is only necessary and recommended when working 
with mod_dav version 1.0 or higher. The configuration of any previous version must not be changed!   
 
For full WebDAV functionality, do the following:  
1. In your Apache configuration file (i.e. httpd.conf), enter the following line:  

DAVDepthInfinity On.  
2. Restart the server to save the new configuration.  
 
To get the latest information on WebDAV see also http://www.webdav.org. 
 
 
------------------------------------------ 
 
7. Undocumented Features and Shortcuts 
 
For an overview of the outstanding and new features in Adobe GoLive 5.0, please consult the 
NewFeatures.html document included on the application CD or in the download archive. The  
NewFeatures.html will also be installed to your hard disk with the GoLive 5.0 installer. 
 
Optimize JavaScript Library 
In response to overwhelming customer demand during beta testing, you can now streamline and optimize the 
size of the external JavaScript library (CSScriptLib.js) for sites created with GoLive. In the Site window, open the 
contextual menu and select Flatten Script Library. With this command GoLive removes from the file the 
JavaScript code for Actions not used in your site thus reducing the size of the CSScript:ib.js file and optimizing 
the performance of your site. In essence, all JavaScript code for an entire site is cached like a single image file. 
NOTE: If you incorporate any new GoLive Actions not yet reflected in this optimized file, GoLive will 
automatically reset the CSScriptLib.js file to include all Actions, thus alerting you that you should optimize the 
JavaScript Library again and upload to your Web server. 
 
Detach Components (SDK implementation) 
If you want to detach one or several Components into a separate, editable item, choose Special > Detach 
Component, or Special > Detach All Components, respectively. (This new feature has been added via an Adobe 
GoLive SDK extension that is located in the Modules\Extend Scripts folder.) 
 

http://www.webdav.org/


Assigning Color to Text 
You can now assign color to text on-the-fly: Highlight the text, and Control-click (Mac) or Right-click (Windows) 
the color icon in the Tools palette to bring up the Color palette. Then, select any color from the Color palette to 
change the color text immediately without dragging it over the text. 
 
Image Maps 
The image map, including the source code <area> element, is now represented by a small yellow square icon 
which appears in the page layout. By default, the icon appears next to the image which includes the hot spot. 
The small map icon can be handled as any other object in the page, so, you can copy, paste, and drag it. By 
dragging it to another location within the page layout, you can control the placement of the <area> element in 
the source code. This may affect how fast a page loads in the browser. 
 
Due to the implementation of this map icon, the procedure to copy image maps has slightly changed: 
• If you want to copy an image with an image map attached to a different document, drag the cursor to select 

both the image and the image map icon, copy the selection, and paste it into the other document‘s page 
layout window. 

• You can also copy the image without copying the image map attached by just selecting the image (and not 
the image map icon). Copy the image and paste it into the other document’s page layout window. 

• When you copy an image with an image map attached into the same document, both images will use the 
same image map in that they will reference the same <area> element. 

 
 
Hide all Palettes 
Press Ctrl+Tab (Mac) or Ctrl+J (Win) to hide/show all open GoLive 5.0 palettes. 
 
Insert Non-Breaking Spaces in Table Cells 
When selecting one or more table cells you can insert non-breaking spaces into these cells via a contextual 
menu command. 
 
Add Table Rows/Columns 
Via a contextual menu you can now add row or columns before or after the current selection. 
 
Merging Table Cells 
When selecting two or more continuous table cells, you can now merge them via a contextual menu command. 
This works the same as the Row Span and Column Span commands in the Table Inspector. 
 
Moving Table Cells 
Multiple and non-contiguous cell selections may now be moved by pressing any of the arrow keys. 
 
Table to Layout Grid Conversion 
When converting an HTML table to the GoLive Layout Grid, any objects, including images inside a cell, are no 
longer placed into a text box (which created padding issues in previous versions). NOTE: This feature does not 
apply to cells containing multiple objects. 
 
Layout Grid Table Code 
The table code has been optimized so it takes advantage of spans to reduce the table code. This can result in 
significantly smaller table code and thus file size reduction. 
 
Layout Grid Control Row and Column 
The control row and control column of the Layout Grid are now bottom and right instead of top and left. This 
means that you can completely remove browser offset on a page, even with a Layout Grid. 
 
Page Margins 
You can now set the page margin to zero via contextual menu when Ctrl-clicking on the page icon. In the same 
way you can reset the page margin to the GoLive 5.0 default setting of 8 pixels. 
 



Outline Mode 
• By holding down the Option key (Mac) or Shift key (Windows) while switching to Outline mode, you can 

toggle between expanding/collapsing tags in Outline mode. 
• If you select an object in Layout or Source mode and switch to Outline mode, 
• only the selected object is revealed. 
• To expand everything in the Outline mode, select the opening HTML tag, and press 
• Option (Mac) or Alt (Windows) + right arrow. 
• To highlight the bugs in a page in Outline mode, turn on Link Warnings in the toolbar. 
 
 
------------------------------------------ 
 
8. Changed Features and Shortcuts 
 
Web Settings/CSS Tab 
In the CSS tab of the Web Settings dialog box, the Use Style Sheet option has been removed. 
 
Clean Up Site Command 
The Clear Site command has been renamed to Clean Up Site. This change is not reflected consistently 
throughout the GoLive 5.0 User Guide, e.g. in the index it still states Clear Site. 
 
Movie Commands 
The following commands in the Movie menu have been renamed: 
• Font > Size was renamed to Text > Size. 
• Font > Style was renamed to Text > Style. 
• Font > Color was renamed to Text > Color. 
 
Site Export/Uploading and Updating Sites 
When publishing a site, the command Export Upload for uploading and updating a site has been renamed to 
Upload All. 
 
Site Export/Strip HTML Command 
When exporting a site, the command Strip HTML Code > Linefeeds is no longer supported since this may 
corrupt foreign script code like ASP. 
 
Color Palette 
In the Color Palette’s menu, the PMColorPickerModule has been renamed to Site Color List. 
 
 
------------------------------------------ 
 
9. Tips for working with GoLive  5.0 
 
Network Status Report 
The Network Status report logs all connections to Web servers. To specify what information is to appear in the 
report, choose Edit > Preferences, expand the Network icon, and select Network Status. 
Note: Choosing more items may degrade performance. Errors are always tracked no matter how many items 
you choose. 
 
Upload Modified option with imported GoLive 4 Sites 
When importing a GoLive 4 site into GoLive 5.0, all files are marked as unmodified for the Upload Modified 
option as Upload Modified does not take into account any files on the server to avoid possible problems with 
server timestamps as well as for performance reasons. Therefore, when importing a GoLive 4 site into 
GoLive 5.0, you should make sure that the site is synchronized with the server before updating it to GL 5. 
 
Source Code Palette 
Selections made in the Source code palette will only be mirrored in the Layout tab after resetting the focus on 
the document window by clicking its title bar. 
 



Applying a Background Image 
You can apply a background image to a page by dragging a GIF, JPEG or PNG file onto the page icon in the 
GoLive document window. 
 
CSS/Renaming Styles 
When renaming styles in the Style sheet window, do not forget the respective prefix in front of the new name. 
This should be done when changing a Class style name as Adobe GoLive software does not automatically 
insert the period in front of Class names (a prerequisite in supporting 360Code™). Styles without prefixes will be 
listed as Element Styles in the Style Sheet window. 
 
Saving Custom Files 
Before removing, re-installing, or updating the GoLive 5.0 application, we strongly recommend you save all your 
custom files to a different directory. This includes the following: 
• Personal dictionaries – all files with a *.UDC extension from the Modules > Dictionaries folder. 
• Any custom files from the Modules > Shortcuts folder. 
• Any custom files from the Modules > Find by Element Tasks folder. 
• The file styles.xml from the Modules > TableStyles folder if you defined your table styles. 
• Files from the Modules > Web Settings folder if you made modifications to the Web Settings. 
• SDK JavaScript extensions from the Modules > Extend Scripts folder. 
• Any custom or third-party actions from the Modules > JScripts > Actions folder. 
• The file AGLPalette.dat from the Modules folder if you stored objects in the Custom tab (otherwise this file 

will not exist) 
• Custom site templates from the Site Templates folder. 
• Any plugins from the Plug-ins (Mac) or Plugins (Windows) folder. 
 
Updating the External, Colors, or FontSets Tabs of the Site Window  
When updating the External, Colors, or Fontsets tabs, all the pages in the root folder are scanned for the 
corresponding objects, and any object found on a page but not listed on the tab is added to the list. In order 
for the rescan to work correctly, you must close all document windows. 
 
 
------------------------------------------ 
 
10. Known Issues 
 
PDF File Changes 
When changing the document info of a PDF file that is included in a GoLive 5.0 site, this PDF file will be marked 
in the site window with a broken link warning. In the Link Inspector you will see that an empty reference has 
been created for the PDF file. By assigning a “#”-link destination to this reference, the link warning in the Site 
window will disappear. 
 
ForceFrame Action 
The ForceFrame action from the Actions Plus 1.0 set of actions does not function in GoLive 5.0. 
 
Browser Switch 
When selecting Internet Explorer 5 or Navigator 6 in the Browser Switch options, the Browser Switch  
will also be applied to Internet Explorer 4.x or Navigator 4.x. 
 
Components Display 
When placing a component on a page, the contents will not display, or be properly updated in Layout View 
unless the component page includes the <BODY> tag. Simply open the component page, select the Page 
icon, and under the HTML tab of the Page Inspector, be sure to place a checkmark next to BODY for the 
Write Page Tags option. 
 
Actions in Components 
If you use actions in a GoLive 5.0 component, you can only include this component once in a page. Adding it 
more than once to the same page may corrupt the code. 
 



ASP Code in Tables 
When ASP code is included in a table/layout grid, the formatting of the ASP code may be changed in that the 
white spaces will be rewritten by GoLive. 
 
More Memory for large Sites 
When working with large or complex sites, pages may open very slowly. In this case you should assign more 
memory to GoLive 5.0. 
  
No Wheel Mouse Support on the Macintosh 
The Macintosh version of Adobe GoLive 5.0 does not support the scroll wheel functionality of input devices with 
scroll wheels like the Microsoft Intellimouse or the Logitech USB Wheel Mouse. 
 
Web Settings Attributes 
When changing attributes in the Web Settings, GoLive does not always change accordingly. For example 
setting the image border to zero in the Web Settings will not be applied to image boxes after that. This is a 
known issue and may be addressed in future versions of GoLive. 
 
Importing Sites from GoLive 4.0 
When importing GoLive 4.0 sites into GoLive 5.0, problems may occur when performing an incremental upload 
to the FTP server . Due to different date/time formats in versions 4.0 and 5.0, this may result in asynchronous 
dates/times and lead to uploading the whole site instead of only the changed files. This problem does not occur 
with GoLive 4.01 sites. 
 
FTP Connection 
When the connection to the FTP server is lost unexpectedly, an error message should appear. In some cases a 
random error number is displayed which does not reflect the real problem. 
 
 
____________________________________________________________ 
 
Actions Plus Credits 
Special thanks to the following developers who have made the Adobe GoLive Actions Plus possible: 
- ALAPI, Inc.-Benoit Marsot and Tobias Tornqvist (http://www.alapi.com/): ForceFrame 
- Walter Blady: TargetRemote and ConfirmLink 
- Lefteris Haritou (lef@the.forthnet.gr): Password 
- Cédric Ménard (cedmen@cybercable.fr): VisitorCookie, DeleteCookie, Slideshow, SlideShowAuto, and 
SlideShowAutoStop 
- Matt Ridley (mattman@mattman.net): DailyRedirect, DailyImageURL, and TimeRedirect 
- Paul Vachier (paulv@transmitmedia.com): KillFrame and Target2Frames 
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